Important service notification – KYB UK Incident
Incident Report for W2
Resolved
As of 10:30 today we are happy to say we have been able to resolve the underlying issue with our supplier and UK KYB is now working as expected.

We will continue to monitor this service closely to ensure it is operating as expected.

Sincere apologies for any disruption this issue may have caused.
Posted Mar 23, 2023 - 11:08 GMT
Update
Good afternoon, unfortunately, we are still working closely with our supplier to restore our UK KYB service.

We do not have an ETA for resolution at this time, we shall endeavor to provide updates as soon as there is any change.

Apologies for any inconvenience this issue is causing.
Posted Mar 22, 2023 - 17:17 GMT
Identified
Good afternoon, we have identified an issue with our supplier serving our UK KYB service. We are in contact with our supplier who are endeavoring to resolve the underlying issue, however, we are not able to provide a resolution estimate at present.

Best efforts are being made to restore service but we are currently waiting for updates from our supplier.

Apologies for the inconvenience this may cause.
Posted Mar 21, 2023 - 17:13 GMT
This incident affected: Services (W2-DATA-EKYB-UK-009).