Important: Service Notification
Incident Report for W2
Resolved
This incident has been resolved.
Posted Sep 15, 2019 - 12:28 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2019 - 10:50 BST
Investigating
We are aware of an issue with our component services.

We are currently investigating the issue internally and with our third party supplier(s) and will provide further updates as soon as we have them.
Posted Sep 15, 2019 - 08:54 BST
This incident affected: Services (W2-DATA-EKYC-UK-007).